home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / media-plugins / xmms-mpg123-1.2.10-r1 / xmms-mpg123-1.2.10-r1.ebuild < prev   
Text File  |  2005-12-20  |  744b  |  31 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10-r1.ebuild,v 1.13 2005/07/12 04:59:44 geoman Exp $
  4.  
  5. SLOT="0"
  6. KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
  7. IUSE="ipv6 ssl mmx 3dnow"
  8.  
  9. DEPEND=">=media-sound/xmms-1.2.10-r12
  10.     ssl? ( dev-libs/openssl )"
  11.  
  12. PATCH_VER="2.2.2"
  13.  
  14. PLUGIN_PATH="Input/mpg123"
  15.  
  16. M4_VER="1.1"
  17.  
  18. inherit xmms-plugin
  19.  
  20. src_compile() {
  21.     myconf="${myconf} --enable-mpg123 $(use_enable ipv6) $(use_enable ssl)"
  22.  
  23.     if use x86 && ! has_pic && { use mmx || use 3dnow; }; then
  24.         myconf="${myconf} --enable-simd"
  25.     else
  26.         myconf="${myconf} --disable-simd"
  27.     fi
  28.  
  29.     xmms-plugin_src_compile
  30. }
  31.